www.whkt.net > hiBErnAtE3+spring4.0框架,将jDk7+tomCAt7升级为jDk8+tomCAt...

hiBErnAtE3+spring4.0框架,将jDk7+tomCAt7升级为jDk8+tomCAt...

PROPAGATION_REQUIRED,readOnly PROPAGATION_REQUIRED PROPAGATION_REQUIRED PROPAGATION_REQUIRED PROPAGATION_REQUIRED 这是spring1

你好,tomcat6能和jdk7一起工作的

我用MyEclipse7.0,tomcat6.0,jdk1.6

我自己做了一个基本的spring+struts的小项目, 每次做别的WAR项目都以这个项目做骨架. 没特意做带hibernate的ssh,因为很多项目其实不采用hibernate,有的用JDBC,有的用JDBC TEMPLATE,有的用ibarts 其实往ss里整合hibernate很容易,因为数据库操作通常都是耦合性比较低的,这样换数据库或者换数据库访问层也容易些.

建议新手使用IDE,然后关联tomcat,只需要新建工程,这样开发完成后启动tomcat就可以直接在浏览器中运行了.

具体要看公司,其实公司也是很懒的,除非是有什么很大的版本功能差异,不然就会一直将就着用.一般myeclips 8.5就OK了,因为支持Struts2以及更好的支持Spring和Hibernate ,如果你要搞最新的HTML5开发,可能就要最新版的myeclips 10.0了,个人建议还是用eclipse

原创回答如下:jdk的全名是:java development kit,中文名称叫做java开发工具包,其中也会包含jre-java runtime environment,中文叫做java运行库环境,jre是运行java程序所必需的前提要求,jdk是开发java程序所使用的编译、加载、运行等工

Hibernate是一种强大的可提供对象-关系持久化和查询服务的中间件,它可以使程序员依据面向对象的原理开发持久化类,实现对象之间的关联、继承、多态、组合、集合

用java来建立一个很有价值的web 应用不是一个简单的任务.在架构这个应用时要考 业务层使用Spring;对于持久层我们使用的是Hibernate. 你尽可以取代这里的某个框

相关搜索:

网站地图

All rights reserved Powered by www.whkt.net

copyright ©right 2010-2021。
www.whkt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com